Installation

LS4 is a distributed storage system implemed in Ruby. You can install using RubyGems.

Requirements

Following softwares are required to run LS4:

1. Installing Ruby

If Ruby >= 1.9.2 is already installed, skip to 2. Installing LS4.

On moderen OS, it is provided by the package systems:

## Ubuntu/Debian
$ sudo aptitude install ruby1.9
$ ruby1.9 --version
$ gem1.9 install ls4

## Mac OS X:
$ sudo port install ruby19
$ ruby1.9 --version
$ gem1.9 install ls4

To install Ruby from source, do following commands:

$ wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p180.tar.gz
$ tar zxvf ruby-1.9.2-p180.tar.gz
$ cd ruby-1.9.2-p180

$ ./configure
$ make -j3
$ sudo make install

You may be required to install following packages to build Ruby.

  • openssl-devel (or libssl-dev)
  • zlib-devel (or zlib1g-dev)
  • readline-devel (or libreadline6-dev)

3. Installing Tokyo Tyrant

Tokyo Tyrant is used as a metadata server (MDS) in LS4.

On some OS, it is provided by the package systems:

## Ubuntu/Debian:
$ sudo aptitude install tokyotyrant

## Mac OS X:
$ sudo port install tokyotyrant

To install Tokyo Tyrant from source, do following commands:

## Install Tokyo Cabinet (database manager)
$ wget http://fallabs.com/tokyocabinet/tokyocabinet-1.4.47.tar.gz
$ tar zxvf tokyocabinet-1.4.47.targz
$ cd tokyocabinet-1.4.47

$ ./configure
$ make -j3
$ sudo make install

## Install Tokyo Tyrant
$ wget http://fallabs.com/tokyotyrant/tokyotyrant-1.1.41.tar.gz
$ tar zxvf tokyotyrant-1.1.41.targz
$ cd tokyotyrant

$ ./configure
$ make -j3
$ sudo make install

Next step: Cluster construction

Table Of Contents

Previous topic

Architecture

Next topic

Cluster construction

This Page